Friday , 10 July 2020
iten

Various java problems following setup instructions.


Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12142
    nwimpney
    Participant

    I tried following along with the instructions to setup the toolchain in linux (ubuntu 19.04), but there is a problem with java.

    using the listed PPA I get an error: Package oracle-java8-installer is not available, but is referred to by another package.

    There was a note when installing the PPA which includes a link to a newer PPA, but it doesn’t offer oracle java8, only 11-13.

    When I install java 12, it doesn’t work with eclipse “oxygen.3” as recommended.

    If I install openjdk-8, it seems to work fine as far as I can see. Should I be expecting any issues running this way, or alternatively, has support been added for newer versions of eclipse that run on newer java versions?

    A few steps later, when trying to build the blinky project, I try to run stm32CubeProgrammer, it complains that JavaFX is not installed. This happens whether I have the openjfx package installed, and regardless of whether I’m running openjdk 8, 11, or oracle 12 or 13.

    Any suggestions?

    #12144
    pedro
    Participant

    I use kubuntu 18.04.
    Eclipse IDE 2019-06 works fine with openjdk-11.

    But I can’t run stm32CubeProgrammer due to the openjfx problem.

    Openjfx needs openjdk-8, which is available for ubuntu 18.04 but I do need openjdk-11 for other programs so I will not install openjfx until the issue is solved.

    I have read that I could compile myself openjfx to allow openjdk-11 compatibility but I’m not sure.
    I don’t want to install oracle-java.

    Then, I will stick to eclipse + st-flash as explained in the old versions of the book.

    #12146
    nwimpney
    Participant

    is the gnu-mcu-eclipse plugin compatible with newer versions of eclipse? The book says that it strongly suggests Oxygen.3a since the newer ones aren’t supported. I guess that may have changed since then.
    Is there somewhere to check for compatibility, or is it a try-and-see kind of thing?
    It would be good to get on a newer version, since I imagine compatibility for java 8 is not going to be around forever. (It’s already off the PPAs, only openjdk 8 still remains in ubuntu 19.04)

    for the stm32CubeProgrammer, the CLI version works fine, so I’m just going to use that.


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.